We’re committed to transparency and reliability.
Subscribe for real-time updates on system status and incidents.
Resolved
All issues with our third-party provider are resolved. The platform, including reporting features, should be fully operational.
Monitoring
We have identified the root cause as an outage affecting a third-party infrastructure provider.
Reporting dashboards are currently unavailable, and other platform components may also experience degraded performance or intermittent issues.
We are actively monitoring the situation and will provide updates as we receive additional information.