We’re committed to transparency and reliability.
Subscribe for real-time updates on system status and incidents.
Resolved
GCP has announced resolution of today's service outage. We will continue to monitor the platform to ensure no further disruptions. At this time, platform capabilities are once more fully operational.
Monitoring
We are continuing to monitor service disruptions related to today’s GCP outage. We will provide additional updates as more information becomes available and share next steps as appropriate.
Investigating
We are continuing to experience intermittent impact in various modules. We are continuing to investigate and monitor.
Investigating
We see that there is still some impact related to our third-party provider. We are now investigating.
Resolved
The issue is now resolved. We will continue to monitor for any additional service interruptions.
Monitoring
We have identified an issue with a third-party service-provider which caused temporary disruption. The issue appears to be resolved and we are actively monitoring its status to ensure reliable access. The platform is now operating as expected.
Investigating
We have identified intermittent service disruption preventing platform operations. Our team is immediately investigating the root cause and will provide continuous updates as we learn more.